Cookies help us deliver our services. By using our services, you agree to our use of cookies.OK

Inkscape

Revision as of 23:45, 9 October 2015 by AndrewArmstrong (talk | contribs) (0.91 extension, clarified where to put extensions)

Installation

Inkscape is a brilliant tool for creating SVG files to later use for laser cutting. The download page shows you the installer files for your system; note for a slight increase of speed for complex files on 64bit systems use the Partha builds.

Setup

Geometric Bounding Box

Inkscape is by default set up for outputting to the screen or to a printer rather than as a CAD tool for engineering, and so the bounding boxes for objects include the thickness of the line strokes. Whilst this is also true for the kerf of our laser cut designs we usually want to be able to enter exact measurements for the bounding box sizes of objects that are based on the centres of the line strokes, the thickness of which is irrelevant when imported to LaserCut. To set this behaviour go to the Inkscape Preferences (File -> Inkscape Preferences), under the Tools section select Geometric bounding box.

Inkscape-Tools-Geometric-BB.PNG

Grid Setup

Inkscape-Grid-snap.PNG

Inkscape by default works in pixels as the measurement; for the grids and page size. First of all to change the grids go to the Inkscape Preferences (File -> Inkscape Preferences), under the Grid section select "mm" instead of the default "px". This affects all new files, so select File -> New to open one, and go to View -> Grid to see it in action.

Set the grid setting to "mm"

In addition it may be useful to have the snapping turned on for Snap to cusp nodes on the right hand side. What this will do is allow the nodes you've created (such as corners) to snap to the MM grid for more precise tuning. Usually you'll want your actual lines you're drawing to be reasonably thick to be able to see them more easily - in the Laser Cut 5.3 program they become very thin.

Document Settings and Templates

By default Inkscapes default file will be in pixels with an A4 portrait size. The easiest option to create one using millimetres is to select A4 Landscape from the New menu. You can also change a documents units setting any time under File -> Document Properties and selecting mm instead of px for the Default units.

Set the "Default units" setting to "mm"

You may also be interested in templates for various sizes of material. If you save these to your Inkscape templates folder (under Windows: %appdata%\inkscape\templates, under Linux ~/.config/inkscape/templates ) you can select them from the New menu. If you want to replace the default, rename one of them to "default.svg". This can save a lot of time when creating multiple items! These are all landscape, but you can save whatever basic SVG you want as a new template.

Once your document is set to MM it will import accurately into Laser Cut 5.3.

Usage Tips

Some tips for usage, a full tutorial may come later:

Coloured Paths

Some of the Inkscape colours are exported with the DXF which can be used to mark areas for engraving, different powers or even different orders of cut. Make sure to have the colours match across everything of one type.

Due to the limited DXF colour export (it only does the 7 primary RGB colours) you can use our custom palette for Inkscape.

Generally it is easier to colour engravings as something special, eg:

  • Black - cuts
  • Blue - engraving areas
  • Green - engraving-power cuts
  • Others - other things

See the tutorials on Laser Cut for how to use this powerful feature.

Extra Colours?

There are also alternative ways of converting SVG to DXF that may retain more colours (the Inkscape DXF plugin might be losing some colours in the conversion process that are actually supported by the DXF format). We also have a complete LaserCut palette file which might be useful for this (although it is untested; some of them do not match the AutoCAD DXF colour palette).

Area fills and Layers

You can fill-colour in areas (eg; to show engraving areas) which makes things easier to see, and use layers and transparency to show/hide or overlay different areas. These are all collapsed or ignored when exporting to DXF, which is useful.

Area fill colour also helps determine if a path you've created is really a completed one. A good engrave area is a fully contiguous single line which is joined up to itself, although the DXF export splits the continuous line into one line with two end points which is easily fixed in Laser Cut.

Paths only!

When finishing a file ready to export select the entire document and go to Path -> Object to Path. The only thing a laser understands is paths (lines) and this may catch any you missed if converting an image file over; objects are not supported.

Leave mess in

You can leave in the SVG embedded images (eg; jpegs you are tracing) and the DXF file will simply exclude them when it is created. You can check the import in the Laser Cut demo or by opening the DXF file again with Inkscape.

Extensions

Extensions to Inkscape allow you to use tools other people have made to create good laser-compatible items. Copy extension files to this folder and restart to activate:

  • Windows: %appdata%\inkscape\extensions (note: %appdata% typically refers to \Users\<your-username>\AppData\Roaming)
  • OS X & Linux: ~/.config/inkscape/extensions (note: ~ refers to the user's home directory, typically /home/<your-username> on Linux or /Users/<your-username> on OS X)

Custom Colour Palette

We have created a custom colour palette which contains only the colours which survive the DXF export from Inkscape (both the DXF format and LaserCut support only a very limited number of colours). It can be found in the LaserCut Installation Files at \Nottinghack LaserCut\Inkscape Files\LaserCut_Laser_Palette.gpl. First ensure that you have installed Inkscape and then copy the LaserCut_Laser_Palette.gpl to the following location, depending on the platform:

  • Windows: %appdata%\inkscape\palettes (note: %appdata% typically refers to \Users\<your-username>\AppData\Roaming)
  • OS X & Linux: ~/.config/inkscape/palettes (note: ~ refers to the user's home directory, typically /home/<your-username> on Linux or /Users/<your-username> on OS X)

Once you have copied the palette into the correct location, restart Inkscape if you have it open and then click the small arrow to the far right of the bar of colours at the bottom of the screen. This should pop up a list of alternative palettes to use, you should see a new one what we just installed.

Inkscape custom laser palette.jpg

We also have a complete LaserCut palette file which contains all 39 of the colours in LaserCut 5.3 (there are actually 40 buttons but two are the same colour for some odd reason), only 7 of the colours in this palette will survive the DXF export, other formats may yield better result, please document any successes.

Inkscape custom full laser palette.jpg

Hershey Font

Inkscape hershey text.jpg

Hershey fonts are for engraving nicely on laser cutters. That page details how to install and use them. A mirror will be added here at some point.

Tabbed Box Maker

Inkscape tabbed box maker.jpg

Boxes are a big thing for laser cutters. Everyone makes boxes. We love them. Tabbed Box Maker (broken) [1] (0.48) [2] (0.91) helps make nicely tabbed boxes of all kinds.

DXF file export settings

You must save what you want in the DXF file format. This format is not as reliable to re-edit so keeping the original SVG is recommended, use File -> Save As Copy to do an "export" to DXF:

The correct save option

The DXF file exports:

  • Paths (lines created in your file)
  • Colours of paths

It will exclude:

  • Embedded images
  • Layers
  • Transparencies
  • Fills

The save options can also help a bit. The main thing is it must be set to mm, and the tickboxes vary the output that is imported. The best default is no tickboxes since in both cases they can cause errors when importing into LaserCut! So use:

The best options!

You can stop reading now; this section will probably be removed but is for information

The two tickboxes affect how the different paths of the file are split on save.

See below for which is which
The top no-tickboxes works best, the LWPOLYLINE messes up 3 and 4.

From left to right:

  • No tickboxes - all paths are split (note that this may allow the laser to determine the quickest cutting path better and most of the time is absolutely fine).
  • ROBO-MASTER ticked - the splines (curved lines) are smoothed and kept linked - see the circle on this one is slightly "elongated" and not fully round!
  • LWPOLYLINE ticked - the straight lines in the A's are not split anymore. In fact the A was created by a long use of the polygon tool in Inkscape and connected together at the end point and imported over perfectly. However later tests with more curved lettering shows it starts to miss out vital line vector points and the Unite tool in LaserCut goes awry.
  • Both ticked - both the above occur. It isn't perfect due to the ROBO-MASTER setting making curves less curved however.

Note that in all cases the lines are not perfect (gaps where the splines and straights match up for instance). However after selecting the Tools -> Unite Lines option in Laser Cut provides pretty much the same cut (red line) and engrave (red area) for each one:

Final engrave

Note how the 2nd and 4th picture the circle is not precise!

The main thing to watch with this design was there are 2 cut lines at the bottom lines of the top engrave; these seem to have been united properly on all designs.

However more complex designs using same-colours for some overlapping lines may cause issues if the Unite Lines tool attaches the wrong nodes together (How does it determine what gets linked at a junction?), so the tickboxes would potentially solve some of these. Best bet is to use no tickboxes.